S50LEA

Radioamaterski forum
Danes je 19 Okt 2018, 14:11

Vsi časi so UTC + 1 ura




Napiši novo temo Odgovori na temo  [ 21 prispevkov ]  Pojdi na stran Prejšnja  1, 2
Avtor Sporočilo
 Naslov prispevka:
OdgovorObjavljeno: 01 Apr 2006, 18:31 
Odsoten

Pridružen: 18 Jul 2005, 12:23
Prispevkov: 31
TNX za INFO Sandi!
Zaboravio sam napisati da imam MBTNC i MBpsk rtx koji ispravno rade i sada želim zamjeniti ulazni dio rs232 sa USB adapterom.
Znači da otpada priča u dijelu oko 68HC000 i nekontrolirana predaja.
Uzrok može biti jedino na pločici USB adaptera. Tek danas sam imao vremena, i otkrio da sam "predobro" :x zalemio pinove 1,2,3,4 i 5 od IC3.
Sve je bilo kratko spojeno !!! :x To sam popravio i sada imam neke logične napone na pinovima IC3. Za IC3 koristim 74HCT00 jer drugo nisam našao i mislim da odgovara. Provjerio sam i MAX232 i ispravan je.
I dalje vidim u monitorskom prozoru promet. RTX više ne ide nekontrolirano na predaju. I dalje nemam komunikaciju PC-MBTNC.
Spominješ neku korekciju vrijednosti R1, no to nisam nigdje našao, no to ima veze sa FT232. Ja sam korak ispred :-?
Zbunjuju me neki spojevi. Na izlaznom konektoru ( prema CPU ) spojen je TXD sa pin24 od FT232 a tamo je RXD. Istovremeno je isti izlazni TXD spojen sa pin11 od MAX a tamo je T1in odnosno TXD.
Isto tako izlazni RTS spojen je na pin22 od FT232 a tamo je CTS. Spoj prema MAX na pin10 , sa T2in odnosno RTS izgleda korektno.
Isto tako je zbrkano i ostalo. No ako kod svih ostalih to radi kako treba, onda očigledno moj problem nije u tome.
Prvo moram ovo riješiti i nema smisla pokušavati USB, pa tako ni veće brzine.
Znam da je teško davati savjete na daljinu, ali ako Ti što padne na pamet
preporučam se.... :lol:...TNX.....pozdrav...Zlatko


Na vrh
 Profil  
 
 Naslov prispevka:
OdgovorObjavljeno: 02 Apr 2006, 14:13 
Odsoten

Pridružen: 03 Jul 2001, 01:00
Prispevkov: 686
Kraj: JN66SI
Pozdravljen ponovno Zlatko,

Kaj sta to "MBTNC i MBpsk rtx" ? Te naprave mi niso znane.

Ali si PCB za USB adapter izdelal sam, ali si ploščico dobil od S57UUD?

USB adapter, o katerem govoriva, je razvit za uporabo v S53MV TNC, kot je to razvidno tudi iz PDF dokumentacije na http://www.s5tech.net/forum/techletter. ... 53e8d26093
Konektor za povezavo USB adapterja s ploščo mikrokontrolerja S53MV TNC ima enak razpored pinov, kot je pri originalnem S53MV RS-232 vmesniku z MC..., le 12V mu ni treba pripeljati in tu zadeve preverjeno delujejo na velikem številu primerkov. Ali je nek pin TXD ali RXD oz. RTS ali CTS je odvisno od smeri, iz katere ga gledaš :). Ali je nek konkretni pin na strani adapterja vhod ali izhod, najbolje in najlažje preveriš iz datasheeta MAX232 oz. 74HC00. Pri oznakah sem pazil, da so maksimalno kompatibilne z oznakami originalne S53MV RS-232 plošče.

Ravno danes sem vgradil in oživil še en S53MV TNC z USB adapterjem in povezal s PC prek SLIP na 921k6 bps. Registre sem popravil z "Modem_speedup_to_921k6_XP", seveda sem moral pred tem analogni modem zacasno odinstalirati, kot piše na s57uud forumu ( http://www.s5tech.net/forum/viewtopic.php?t=50 ). Sama komunikacija PC <---> MC68k deluje brez težav. Pred časom sem imel na enem od XP težave z dosego >115k2 hitrosti, sumil sem XPjev SP2, vendar mi je danes povezavo uspelo vzpostaviti na PC z SP2 in najnovejsimi XP posodobitvami.

Flexnet+WPP uporabljam samo do 115k2, več itak nima pravega smisla. Višja hitrost prek USB pokaže svoj čar šele pri IP komunikaciji prek AX.25 in SLIP povezavi s PC.

LP, Sandi


Na vrh
 Profil  
 
 Naslov prispevka:
OdgovorObjavljeno: 07 Apr 2006, 14:14 
Odsoten

Pridružen: 18 Jul 2005, 12:23
Prispevkov: 31
Hojla Sandi!
MBTNC=mega bitni TNC prema CQZRS 2000/4/29
MBpsk rtx= psk radijska postaja prema CQZRS 1996/2/23
Na obadva mjesta su i u naslovima tako nazvane "igračke" :D
PCB za USB adapter sam dobio preko S57C, izvor mi nije poznat
Sve što si napisao je logično !!!
Na kraju je kod mene naprava proradila. (ulaz DB9 via MAX232 i 115k)
Instalirao sam VCP driver ver 1.09.06. na WIN98. Ide li isti driver i za XP? Što znači stari driver i novi ( kako piše u članku u CQZRS ). Pod tim imenima na ftdichip nema dokumenata :-?
Spojio sam i USB kabel i taj dio radi na 115k.
U jednom postu si spomenio krivo označeni R1. Kolika je točna vrijednost ?
Napisao si " seveda sem moral pred tem analogni modem zacasno odinstalirati " prije popravka registara. To ide za WIN98 sa programčićem "modem speedup to 921k6 by s52zo.reg" na stranici S57C ? Koji si to modem morao odinstalrati ?
Preostalo mi je još speed update...i naravno srediti SLIP-dial up 28800 Hvala na dosadašnjoj pomoći :lol: ...pozdrav...Zlatko


Na vrh
 Profil  
 
 Naslov prispevka:
OdgovorObjavljeno: 07 Apr 2006, 22:18 
Odsoten

Pridružen: 03 Jul 2001, 01:00
Prispevkov: 686
Kraj: JN66SI
Za XP ni isti driver kot za 98. Sedaj so že vsi driverji nove verzije, "MS certified", ko sem pisal članek v CQ ZRS, še niso bili.

Modem (običajni analogni, vgrajen v PC) sem moral odinštalirati pod XPji, da je "speedup" prijel na 28800 standard modem prek VCP za FT232BM.

V eni verziji XP sem imel težave z delovanjem na 921k6, čeprav se je v vseh oknih lepo nastavilo na to vrednost. Potem sem v "modem settings / troubleshouting / log" opazil, da Windowsi modem dejansko inicializirajo na 115k2. Ko sem ponovil nastavitve na 115k2 in nazaj na 921k6, je šla inicializacija OK. Računalništvo pač ni exaktna znanost :). Malo je treba eksperimentirati, potem deluje.

LP, Sandi


Na vrh
 Profil  
 
OdgovorObjavljeno: 16 Jun 2006, 22:05 
Odsoten
Uporabniški avatar

Pridružen: 05 Feb 2004, 09:05
Prispevkov: 1471
Na mojih XP-jih deluje.
Instalacija je enostavnejša.
http://www.ftdichip.com/Drivers/VCP.htm
Navodila za instalacijo:
http://www.ftdichip.com/Documents/InstallGuides/Windows_XP_Installation_Guide.pdf

Port speedup popravek v registru je tukaj:

http://lea.hamradio.si/~s57c/razno/Modem%20Baudrate%20XP/

Jutri pa isprobam še v živo!


Na vrh
 Profil  
 
OdgovorObjavljeno: 17 Jun 2006, 06:23 
Odsoten

Pridružen: 03 Jul 2001, 01:00
Prispevkov: 686
Kraj: JN66SI
s55m napisal/-a:
Na mojih XP-jih deluje.


Živijo Adi,

Tudi pri sebi sem si vmes instaliral še na enem prenosniku (XP z najnovejšimi popravki) in je "špilalo" s prve. Seveda potem, ko sem pravilno nastavil X.25 in IP parametre :). Sami XP-ji pa niso povzročali težav.

LP, Sadni


Na vrh
 Profil  
 
Prikaži prispevke prejšnjih:  Razvrsti po  
Napiši novo temo Odgovori na temo  [ 21 prispevkov ]  Pojdi na stran Prejšnja  1, 2

Vsi časi so UTC + 1 ura


Kdo je na strani

Po forumu brska: 0 registriranih uporabnikov in 3 gostov


Ne morete pisati prispevkov v temi
Ne morete odgovarjati na teme v forumu
Ne morete urejati prispevkov v temi
Ne morete brisati vaših prispevkov forumu
Ne morete dodati priponk prispevkom

Išči za:
Pojdi na:  
Powered by phpBB® Forum Software © phpBB Group